Średnia ważona w Excelu


Średnia ważona to średnia wartości, którym przypisane są wagi (znaczenia) im wyższa waga tym wartość ma większy wpływ na wynik średniej ważonej i odwrotnie im mniejsza waga tym mniejszy wpływ na wynik średniej ważonej.

Obliczenie średniej ważonej rozpoczyna się od przemnożenia wartości przez wagi, a następnie otrzymane wyniki sumuje się. Tak otrzymany wynik należy podzielić przez sumę wag.

W bibliotece funkcji Excela nie ma formuły do wyliczenia średniej ważonej, dlatego do jej obliczenia można wykorzystać formuły sumę iloczynów oraz sumę. Gdzie wynik sumy iloczynów (iloczyn wartości i wag) zostanie podzielony przez sumę wag. Sposób obliczenia średniej ważonej w Excelu prezentują poniższe przykłady.


Przykład 1

Oblicz średnią ważoną cenę zakupu akcji.

Data transakcji Akcje Cena jednej akcji Ilość akcji
2016-08-01 Spółka XYZ 125,50 200
2016-08-02 Spółka XYZ 126,80 100
2016-08-03 Spółka XYZ 130,02 50
2016-08-04 Spółka XYZ 128,15 150

 

Krok 1 Ustalenie wagi

Obliczasz średnią cenę akcji, dlatego wagami są zakupione ilości akcji.

Krok 2

Przemnóż cenę akcji przez ilość akcji, a następnie podsumuj otrzymane wyniki.

=125,50 * 200 + 126,80 * 100 + 130,02 * 50 + 128,15 * 150=63 503,5

W Excelu dla ułatwienia i zaoszczędzenia czasu możesz posłużyć się formułą suma iloczynów. Formułę tą odnajdziesz w grupie formuł Matematycznych i trygonometrycznych. Argumentami formuły są Tablice. W polu Tablica 1 zaznacz komórki zawierające ceny po jakich akcje były kupione, a w polu Tablica 2 zaznacz komórki z wagami, czyli ilościami kupionych akcji. Zakończ wstawianie formuły klikając przycisk OK.

biblioteka funkcji suma iloczynów

suma iloczynów argumenty

 

Krok 3 Suma wag

Otrzymany wynik podziel teraz przez sumę wag (ilości kupionych akcji).

Do komórki D6 wstaw autosumowanie. Suma wag w przykładzie wynosi 500.

suma wag

 

Krok 4 Obliczenie średniej ważonej

Otrzymane wcześniej wyniki podziel przez siebie. Średnia ważona cena jednej akcji jest równa 127,007.

średnia ważona wynik

excel średnia ważona

 

Przykład 2

Dla zestawu danych z pierwszego przykładu zostanie wyliczona średnia ważona w Excelu, jednak teraz cała formuła zostanie umieszczona w jednej komórce. Zapis będzie miał następującą postać.

=SUMA.ILOCZYNÓW(C2:C5;D2:D5)/suma(D2:D5)

excel średnia ważona

Comments are closed.

post